Journal File Editor

The Journal File Editor is a built-in, multi-document text editor that can read, edit, play, and translate Trelis journal files and Python Scripts. To open the journal file editor, select the  icon on the File Tools toolbar, or from the Tools Menu.
 

Figure 1. The Journal File Editor

The Journal File Editor can be used to create a new Python or Trelis command script. By default, a new journal file will be in Trelis command syntax. You can change the default in the options dialog. On the "General" options page, under the Journal Editor heading, you can select the default syntax. You can change the new journal file's syntax using the translation buttons as well. When you have the correct syntax selected, enter the commands in the order you want them executed. You can play the commands all at once using the play button on the tool bar. You can also play a few commands at a time. Select the commands you want to play. Then, right click and select the "Play Selected" menu item.

The Journal File Editor can also be used to edit an existing journal file. Use the File > Open menu item to open the file you want to edit. You still have all the command play options with an existing journal file.

You can import commands entered in the Command Line Workspace. The File > Import menu item contains a list of available imports. Select the tab you want to import from. Only the current commands will be imported from the command line. Some of the commands you previously entered might not show up if you have the recommended text trimming turned on. Text trimming improves the application's performance for speed and memory. It will trim off the oldest text in the window when a size limit is reached. To get all the command from your current session, make sure that command journaling is turned on.

The Journal File Editor can be used to edit Python or Trelis command scripts. It can also translate between the two forms. Translating from Python to Trelis commands can cause commands to be lost. The Journal File Editor will warn you when doing so.

The Journal File editor can be used to edit multiple files at the same time. Each document is displayed in its own tab. The tab shows the journal file's syntax and name. If you close the Journal File Editor with unsaved data, it will prompt you to save changes for each of the modified journal files you have open.

Journal Editor Toolbar

The Journal Editor's Toolbar provides quick access to several important functions.

Other Functionality Available in the Journal Editor

The context ('right-click') menu in the journal editor includes several additional functions, including: